「Arduino Mega 2560 LESSON:3 異なる値の抵抗を使用してLEDの輝度を変更する」の版間の差分
編集の要約なし |
(→概要) |
||
| 392行目: | 392行目: | ||
抵抗は、抵抗を選択して表示される値編集ダイアログでValue値を220Ωを示す220を入力すると回路図がわかりやすくなります。 | 抵抗は、抵抗を選択して表示される値編集ダイアログでValue値を220Ωを示す220を入力すると回路図がわかりやすくなります。 | ||
[[ファイル:Mega2560 L02 11 回路図.png|380px||none|回路図]] | |||
回路図を描き終わったら、[検査]-[ERC(エレクトリカル ルール チェック)]ダイアログを起動して、チェックをしましょう。問題なければ次のフットプリントの適用作業をするためのダイアログ起動をして次の作業に進めます。ときだきCtrl+Sでプロジェクトの現在までの編集内容を保存するようにしましょう。 | 回路図を描き終わったら、[検査]-[ERC(エレクトリカル ルール チェック)]ダイアログを起動して、チェックをしましょう。問題なければ次のフットプリントの適用作業をするためのダイアログ起動をして次の作業に進めます。ときだきCtrl+Sでプロジェクトの現在までの編集内容を保存するようにしましょう。 | ||
フットプリントは[ツール]-[フットブリント割り当て]で起動するフットプリントを割り当てダイアログで実施します。電子回路を組むときに選んだ部品にはデフォルトのフットプリントが定義されている部品もありますが、だいたいは、思っていたのと異なるフットプリントになっていることがあります。全部定義し直さないといけないと思っていて間違いないでしょう。 | |||
今回は以下のようにフットプリントを割り当てます | |||
*LED:「LED_D5.0mm」:LED_THT:LED_D5.0mm | |||
*Conn_01x02:「PinHeader_2.54mm」:Connector_PinHeader_2.54mm:PinHeader_1x02_P2.54mm_Vertical | |||
*220:「DIN0207」:Resister_HTH:R_Axial_DIN0207_L6.3mm_D2.5mm_P10.16mm_Horizontal | |||
適用して回路図を保安&続行を押すとフットプリントの割り当て作業の途中で保存処理ができます。 | |||
終わったら保存をおして、もう一度ERCを実行しておきましょう。 | |||
したらば、次のPCBエディターでの作業に移りたいので、メニュー[ツール]-[回路図から基板を更新] F8を選択します。F8キーを押すのが通です。するとPCBエディタに移動して、小さなダイアログが表示されるので、そのまま[基盤を更新]をおして、圧縮されたような回路図を適当な位置に配置します。今置いた方がPCB回路図全体です。中には抵抗、2ピンコネクタ、LEDの要素で構成されているものがあるので、個別に選択することができます。部品を選択するときはRキーとか拡大縮小はマウスホイールの真ん中を押しながら…みたいな操作感は回路図のエディターと同じです。 | |||
ここからは知恵の輪を解くような作業がはじまります。配線を引いたときになるべく重ならないような配置。部品の回転方向を決めます。そして重ならないように配線がひけるとおもったところから、それぞれの部品の配線コネクタを選択してXキーを押すと配線開始モードになります。ときどき任意の点でクリックしておりまげることを確定させながら目的の配線へと繋ぎます。うすい線で繋がっていたものが消えます。薄い線は、これとこれを繋がないと駄目ですよという指標で部品と部品を他の部品の上とかを貫通しながらまっすぐな線でつないでいます。赤い線で配線がつながると細い線は消えます。Escキーを押すとまた選択モードになるので、これで既に配線した部分を選択してDELキーを押すと配線が消えていきます。そうやって消してからやりなおしてもいいでしょう。 | |||
部品の外回りをする方向にも通路はあるので、そこをみのがさず結線を考えます。どうしても重なってしまう場合には、2層目とかを使う技がありますが、今は大丈夫だと思うのでここでは説明しません。 | |||
うまくいったらメニュー[配置]-[フットプリントを配置]からフィルター「M3」で選択できるMountingHole_3.2mm_M3 説明Mounting Hole 2.2mm, M3, no annula, generated by kikcad-footpring-generator mountinghole.pyを選択して4隅に配置してみてもいいでしょう。これは基盤にねじ止め用の穴をあけるためのホールを意味します。 | |||
2026年10月3日 (土) 19:26時点における版
概要
LESSON2です。異なる値の抵抗を使用してLEDの輝度を変更するという内容です。ブレッドボードを使うLESSONになっています。
ブレッドボードは上記のような形式で、薄緑の線で描いた部分が内部で繋がっています。この接続をうまく利用していくつかの回路を仮で実現する簡易的な回路作成器になります。接点数がおおいほど内部抵抗が多くなるので誤差が大きくなっていきます。
このLESSONで使う回路は以下のようなものです。
LEDがTinkercadでは右にしかプラス端子を持ってこれないのでクロスするカタチで結線されていますが、+5V→抵抗(220Ω/1kΩ/10kΩ)→LED→GNDという回路です。
■220Ω抵抗のLED点灯(明るい)
■1kΩ抵抗のLED点灯(中くらい)
■10kΩ抵抗のLED点灯(暗い)
LESSON2の内容は説明書ではここまでですが、デジタルマルチメータ―を持っているので、各箇所の電圧を測って、電流値を予測し、消費電力の概算をしてみましょう。
実物では、DC5Vを供給するのにPCとUSB接続しているときは、入力電圧が不安定になり、4.78~4.90Vで揺らいでいました。PD充電にすると5.030~5.035Vで比較的安定。付属の9V DC Inputを利用すると5.015Vでかなり安定している感じでした。付属の9V DC Inputを利用するようにして最終的に実験しました。また、配線が多すぎる取り回しをしたので、220Ωの抵抗を取り付けている状態でMega 2560のDC5Vピン→抵抗の+側の電圧を測ると20.8mV、LEDのマイナス側→Mega 2560のGNDピン側の電圧を測るGND側で73mVの電圧降下があり合計94mVの電圧降下が確認されました。わりかしロスするので高い電流になればなるほど、回路部品以外での電圧降下が顕著になります。
- 10(9.95)kΩ 抵抗部=3.000V、LED部=1.755V 抵抗+LED(電源-GND)=4.760V
- 1(0.995)kΩ 抵抗部=2.830V、LED部=1.879V 抵抗+LED(電源-GND)=4.850V
- 220(222.5)Ω 抵抗部=2.780V、LED部=2.020V 抵抗+LED(電源-GND)=4.800V
- 10kΩ:約0.302mA
- 1kΩ:約2.84mA
- 220Ω:約12.49mA
抵抗があることで、引き込む電流が変化していることに注目すべきですね。つまり、これは抵抗が大きいのが付いてる方がLEDは暗くなり消費電力が抑えられていることを意味します。消費電力は
\[ W=I^{2}R=VI \]
で計算できるので
| 抵抗 | 電流 | 抵抗の消費電力 | LEDの消費電力 | 回路全体 |
| 9.95kΩ | 約0.302mA | 約0.905mW | 約0.529mW | 約1.44mW |
| 995Ω | 約2.84mA | 約8.05mW | 約5.34mW | 約13.8mW |
| 222.5Ω | 約12.49mA | 約34.7mW | 約25.2mW | 約60.0mW |
ELEGOOのLessonでは安全に実験できる構成が示されている。一方、付属LEDの型番やデータシートが確認できないため、その部品固有の定格や特性までは分からない。そこで今回は、教材で使用される範囲を大きく外れない範囲で実測し、おおまかな \(I_F-V_F\) 特性を確認してみることにする。
\( I_F \)(Forward Current:順方向電流)-\( V_F \)(Forward Voltage:順方向電圧)特性
測定を増やした結果は以下の通り
| 実測抵抗値 | 抵抗電圧 VR V_R | IF I_F | VF V_F |
| 9.95kΩ | 3.000V | 0.302mA | 1.755V |
| 7.11kΩ | 3.173V | 0.446mA | 1.772V |
| 5.124kΩ | 3.196V | 0.624mA | 1.787V |
| 1.998kΩ | 3.060V | 1.532mA | 1.834V |
| 995Ω | 2.830V | 2.844mA | 1.879V |
| 658Ω | 2.840V | 4.316mA | 1.911V |
| 442.6Ω | 2.810V | 6.349mA | 1.931V |
| 222.5Ω | 2.780V | 12.494mA | 2.020V |
\( I_f - V_f \)特性は以下のとおりです。
| IF (mA) | VF (V) |
| 0.302 | 1.755 |
| 0.446 | 1.772 |
| 0.624 | 1.787 |
| 1.532 | 1.834 |
| 2.844 | 1.879 |
| 4.316 | 1.911 |
| 6.349 | 1.931 |
| 12.494 | 2.02 |
グラフにすると以下のような感じ
つまり、このような表をみて、最大の明るさ付近である12mAで2Vになるあたりを使いたいなと思ったら、ソース電圧\( V_S \)と\( V_f \)の差から\( 5 - 2 = 3 \)という値から \( 3 \div ( 12 \times 10^{-3}) = 250 \)と計算して、必要な抵抗は\( 250[Ω] \) あたりだと計算できます。したがって抵抗の算出式は
\[ R = \frac{V_S - V_f}{I_f} \]
となりますね。自分で抵抗を決められるようになるね。
Tinkercadでも同じ実験をしてみた。実物でないとわからないことも多かったので、Tinkercadだけで学習しなくてよかったかもしれない。でもこちらでも各種電圧測定をやっておこう。理想形の答えがここにあるだろう。
回路図部分でマウスホイールを動かすと拡大縮小ができて、なにもないところをドラックアンドドロップすることで回路図全体を移動できる仕組みになっています。
ブレッドボードを追加するには、Arduino Unoを追加したときのような感覚で、ブレッドボードを回路図表示部分にドラッグアンドドロップすればよいです。抵抗とLEDも同じようにドラッグアンドドロップでブレッドボード内の所望の位置で配置しましょう。
配線はブレッドボードの穴や、Arduino Unoの端子の穴などの接点にカーソルを持っていくと四角いアイコンになるので、そこでクリックして、また接点や穴の位置でクリックすると2点間が結線されます。色は上部のツールバーみたいな部分で選べます。
マルチメータ―も存在していますので、同じように結線をすると、シミュレーション開始したときに測定ができるようになっています。今回は電圧計だけを使いました。
抵抗値は抵抗をアクティブにしたときに現れる設定ダイアログから抵抗値を指定できます。LEDは特性は選べなくて、色だけが選べます。こちらもスターターキットと同じく謎のLEDですね。
- 10kΩ 抵抗部=3.23V、LED部=1.77V 抵抗+LED(電源-GND)=5V
- 1kΩ 抵抗部=3.11V、LED部=1.89V 抵抗+LED(電源-GND)=5V
- 220Ω 抵抗部=2.980V、LED部=2.02V 抵抗+LED(電源-GND)=5V
| 抵抗 | 電流 | 抵抗の消費電力 | LEDの消費電力 | 回路全体 |
| 10kΩ | 約0.323mA | 約1.04mW | 約0.572mW | 約1.62mW |
| 1kΩ | 約3.11mA | 約9.67mW | 約5.88mW | 約15.6mW |
| 220Ω | 約13.55mA | 約40.4mW | 約27.4mW | 約67.7mW |
最後にKiCadでガーバーを作るところまで作業しておきました。
KiCADを起動します。
メニュー[ファイル]-[新規プロジェクト]を選択します。
テンプレートから[Default]を選択して[OK]ボタンを押します。
今回はプロジェクト名に「LED_Test」と指定してMy Documentの下のKiCADフォルダの中で作りました。
「LED_Test.kicad_sch」の項目をダブルクリックして回路図スケッチを起動します。
回路図を作成します。Aキーで部品を追加、ESCキーで部品追加やワイヤー編集などの特定のモードから脱出して、部品選択状態に、Rキーで追加した部品を回転、Eキーで選択した部品のプロパティを設定、Pキーで電源部品を追加、Wキーでワイヤー接続モードになります。部品を追加や、電源部品を追加ではものすごい数の部品があるので、かなりの部品絞り込み知識が必要になります。ChatGPTに相談しながら選択するのが楽です。
今回は部品はフィルター「R」で選択できる、アイテム:R、説明:Resisterを選択。
- 「R」:R:Resister
- 「LED」:LED:Light emitting diode
- 「Conn_01x02」:Conn_01x02:Generic connector, single row,01x02, script generated(kicad-library-utils/schlib/schlib/autogen/connector/)
電源部品はフィルター「+5V」で選択できるアイテム:+5V、説明:Power symbol a global label with name "+5V"
- 「+5V」:+5V:Power symbol a global label with name "+5V"
- 「GND」:GND:Power symbol a global with name "GND", ground
- 「PWR_FLAG」:PWR_FLAG:Special symbol for telling ERC where power comes from
を使います。
ワイヤーは始点でクリック、終点でダブルクリックするようです。
あくまでも作りたいのはフットプリントや、銅箔の位置などですのでフットプリントにつかう部品にあわせた電子部品回路を組むことです。+5VとGNDの位置にはPWR_FLAGを1つ、つけます。+5VとGNDはつながなくても複数配置すれば、同じシンボル同志は繋がっているものとして判定してくれます。
回路図内で拡大・縮小したいときはマウスホイールを押し込みながら回転
回路図内の表示全体を移動したいときは、マウスホイールを押しながらドラッグすると移動します。押し込まないとスクロール量として処理されます。マウスホイールを押すことは拡大縮小ツールを選んだことになるので、押した後はスクロールすると拡大縮小として処理されることがあります。Escキーで拡大縮小機能を終わらせるとまた、スクロール量として処理されます。
抵抗は、抵抗を選択して表示される値編集ダイアログでValue値を220Ωを示す220を入力すると回路図がわかりやすくなります。
回路図を描き終わったら、[検査]-[ERC(エレクトリカル ルール チェック)]ダイアログを起動して、チェックをしましょう。問題なければ次のフットプリントの適用作業をするためのダイアログ起動をして次の作業に進めます。ときだきCtrl+Sでプロジェクトの現在までの編集内容を保存するようにしましょう。
フットプリントは[ツール]-[フットブリント割り当て]で起動するフットプリントを割り当てダイアログで実施します。電子回路を組むときに選んだ部品にはデフォルトのフットプリントが定義されている部品もありますが、だいたいは、思っていたのと異なるフットプリントになっていることがあります。全部定義し直さないといけないと思っていて間違いないでしょう。
今回は以下のようにフットプリントを割り当てます
- LED:「LED_D5.0mm」:LED_THT:LED_D5.0mm
- Conn_01x02:「PinHeader_2.54mm」:Connector_PinHeader_2.54mm:PinHeader_1x02_P2.54mm_Vertical
- 220:「DIN0207」:Resister_HTH:R_Axial_DIN0207_L6.3mm_D2.5mm_P10.16mm_Horizontal
適用して回路図を保安&続行を押すとフットプリントの割り当て作業の途中で保存処理ができます。
終わったら保存をおして、もう一度ERCを実行しておきましょう。
したらば、次のPCBエディターでの作業に移りたいので、メニュー[ツール]-[回路図から基板を更新] F8を選択します。F8キーを押すのが通です。するとPCBエディタに移動して、小さなダイアログが表示されるので、そのまま[基盤を更新]をおして、圧縮されたような回路図を適当な位置に配置します。今置いた方がPCB回路図全体です。中には抵抗、2ピンコネクタ、LEDの要素で構成されているものがあるので、個別に選択することができます。部品を選択するときはRキーとか拡大縮小はマウスホイールの真ん中を押しながら…みたいな操作感は回路図のエディターと同じです。
ここからは知恵の輪を解くような作業がはじまります。配線を引いたときになるべく重ならないような配置。部品の回転方向を決めます。そして重ならないように配線がひけるとおもったところから、それぞれの部品の配線コネクタを選択してXキーを押すと配線開始モードになります。ときどき任意の点でクリックしておりまげることを確定させながら目的の配線へと繋ぎます。うすい線で繋がっていたものが消えます。薄い線は、これとこれを繋がないと駄目ですよという指標で部品と部品を他の部品の上とかを貫通しながらまっすぐな線でつないでいます。赤い線で配線がつながると細い線は消えます。Escキーを押すとまた選択モードになるので、これで既に配線した部分を選択してDELキーを押すと配線が消えていきます。そうやって消してからやりなおしてもいいでしょう。
部品の外回りをする方向にも通路はあるので、そこをみのがさず結線を考えます。どうしても重なってしまう場合には、2層目とかを使う技がありますが、今は大丈夫だと思うのでここでは説明しません。
うまくいったらメニュー[配置]-[フットプリントを配置]からフィルター「M3」で選択できるMountingHole_3.2mm_M3 説明Mounting Hole 2.2mm, M3, no annula, generated by kikcad-footpring-generator mountinghole.pyを選択して4隅に配置してみてもいいでしょう。これは基盤にねじ止め用の穴をあけるためのホールを意味します。
■PCB図
■3Dプレビュー図
